Не удалось выполнить синхронизацию проекта Gradle, Котлин

Я использую бета-канал Kotlin и Android-Studio. После обновления до последней версии я получил некоторую ошибку синхронизации градиента.

Ниже приведен журнал, который я скопировал из журнала событий:

Error:Could not find org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.0-rc-39. Searched in the following locations: file:/home/yourpc/Android/android/gradle/m2repository/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.pom file:/home/yourpc/Android/android/gradle/m2repository/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.jar https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.pom https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.jar https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.pom https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0-rc-39/kotlin-gradle-plugin-1.2.0-rc-39.jar Required by: project : 

ниже – build.gradle

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { ext.kotlin_version = '1.2.0-rc-39' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.1.0-alpha04' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { google() jcenter() } } task clean(type: Delete) { delete rootProject.buildDir } 

ниже показано приложение build.gradle:

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' apply plugin: 'kotlin-android-extensions' android { compileSdkVersion 26 defaultConfig { applicationId "com.udebest.myapplication" minSdkVersion 15 targetSdkVersion 27 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { postprocessing { removeUnusedCode false removeUnusedResources false obfuscate false optimizeCode false proguardFile 'proguard-rules.pro' } } } } dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) implementation"org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support.constraint:constraint-layout:1.0.2' testImplementation 'junit:junit:4.12' androidTestImplementation 'com.android.support.test:runner:1.0.1' androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1' } 

Пожалуйста, у кого есть идея об этом? Я действительно не знаю, как я могу это решить? Я не мог найти там никаких решений.

Измените свои repositories в buildscript и allprojects на:

 { google() jcenter() mavenCentral() maven { url 'https://dl.bintray.com/kotlin/kotlin-dev/' } } 

Это работает для меня.

Удалите плагин Kotlin (Предпочтения> Плагины> Kotlin> Uninstall) и используйте версию, которая поставляется с IDE.

Измените и попробуйте

 classpath 'com.android.tools.build:gradle:3.1.0-alpha04' 

в

 classpath 'com.android.tools.build:gradle:3.0.0' 

Это может быть связано с альфа-выпуском градиента.

Это может быть ваш случай. Плагин kotlin gradle несовместим с последним альфа-плагином Android (2.0.0-alpha6) или alpha5.

Пока это не так, вы можете использовать 2.0.0-alpha3 вместо этого.

Используйте ниже версию kotlin в build.gradle (Project)

 kotlin_version = '1.1.4-3' dependencies { classpath 'com.android.tools.build:gradle:3.0.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } 

Объявить зависимость kotlin в build.gradle (Module), как показано ниже

 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version"