Intereting Posts
идея не может найти класс для импорта Kotlin: Почему унарный плюс / минус не способен вывести общий тип из назначения? Android Kotlin не может использовать list.sort () с lambda Может ли перегрузка операторов сравнения в Kotlin использоваться для реализации SQL-подобных функций? Преимущества LINQ над функциональными цепочками методов Как перевести класс Java в класс данных Kotlin Неразрешенная ссылка: sun.misc.MessageUtils.where Захват ArgumentCaptor, возвращающий значение null Невозможно преобразовать в коллекцию в котлин kotlin test whith mockito: сравнение Failure Как правильно обращаться с ошибками при использовании HTTP-клиента в Котлине? Реализовать Hashmap с разными типами значений в Котлине Kotlin назвал синтаксис параметров для закрытия / лямбда Фрагмент isDetached условный не запускается, хотя фрагмент, безусловно, отсоединен kotlin, которая может использовать соединение httpS без проверки сертификата (например, curl – insecure)

Как отладить ошибку «Не удалось разрешить ошибку com.google.android:android» в Anko

compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" //Anko compile "org.jetbrains.anko:anko:$anko_version" compile "org.jetbrains.anko:anko-coroutines:$anko_version" compile "org.jetbrains.anko:anko-appcompat-v7:$anko_version" compile 'org.jetbrains.kotlinx:kotlinx-coroutines-android:0.13' Build error: Error:Failed to resolve: Could not resolve com.google.android:android:2.3.1. Required by: project :app > org.jetbrains.kotlinx:kotlinx-coroutines-android:0.13 

Solutions Collecting From Web of "Как отладить ошибку «Не удалось разрешить ошибку com.google.android:android» в Anko"

У меня такая же ошибка при установке Android Studio 2.4 Preview. Просто убедитесь, что ваш проект build.gradle выглядит так:

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { ext.kotlin_version = '1.1.2-3' repositories { jcenter() mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.3.1' //Version must be exactly 2.3.1 classpath 'com.google.gms:google-services:3.0.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } } 

Удалить строку

 compile "org.jetbrains.anko:anko-coroutines:$anko_version" 

и попробуйте еще раз, пожалуйста. Или вставьте полный файл build.gradle.