Что означает предупреждение «Использовать свойства из пакетов вариантов сборки»?

Что означает это предупреждение?

Он появился в версии 1.0.0-beta-3595 для всех применений расширений kotlin android в моем коде.

Предупреждение Kotlin «Использовать свойства из пакетов вариантов сборки»

Я думаю, что они сделали это для поддержки нескольких вариантов сборки. Например, если у вас есть ароматизатор, и вы хотите использовать макет из этого вкуса, вы должны использовать

 import kotlinx.android.synthetic.proversion.activity_main.* 

Для main варианта сборки вы должны использовать

 import kotlinx.android.synthetic.main.activity_main.* 

Не совсем ответ на вопрос «почему они это сделали», но это то, как устранить предупреждение. + Изменить

 import kotlinx.android.synthetic.activity_main.* 

в

 import kotlinx.android.synthetic.main.activity_main.* 

подразумевая, что вы уже столкнулись с версией в build.gradle и обновили плагины kotlin для IDEA (или AS).