Ошибка сборки приложения Kotlin из-за «Не удалось инициализировать класс com.intellij.ide.highlighter.JavaFileType»

Я только что обновил Android Studio до версии 2.2, и теперь мой проект Kotlin не будет создан. Синхронизация градиента отлично работает, но при попытке сборки я сразу же обнаружил ошибку, которая гласит:

Error:Execution failed for task ':app:compileDebugKotlin'. > Could not initialize class com.intellij.ide.highlighter.JavaFileType 

Я проверил, что мой плагин Kotlin обновлен. Эта ошибка звучит как-то, что связано с IDE и выделяет Java-код? Любая помощь будет оценена по достоинству.

Открыть Tools | Kotlin | Configure Kotlin Plugin Updates Tools | Kotlin | Configure Kotlin Plugin Updates Tools | Kotlin | Configure Kotlin Plugin Updates в главном меню, затем выберите « Check for Updates . Будьте уверены, что вы используете Stable канал.

Закройте Android Studio , перейдите в каталог своего проекта и удалите папки build и app/build . Запустите Android Studio. Удаленные папки будут воссозданы.

Надеюсь, это поможет

В моем случае плагин kotlin не обновлялся, как сказал @piotrek1543 в другом ответе.

В дополнение к этому build.gradle имел старую версию версии 1.0.1-2 а IntelliJ сказал в предупреждении сверху, чтобы перейти к текущей версии 1.0.4 .

Теперь с такой версией kotlin ошибка исчезла:

 ext.kotlin_version = '1.0.4'