Articles of плагины

Как добавить плагин Kotlin для Gradle в Android Studio 3.1 Canary 3

Как интегрировать плагин Kotlin для Gragle в Android Studio (версия 3.1 Canary 3)? Я искал в Интернете и этой документации, но ясного ответа не было. Я не уверен, что следует использовать существующие ответы на этом и других сайтах, потому что было внесено много изменений в интеграцию Kotlin в Android Studio 3.1 Canary 3.

При развертывании плагинов intellij копируются только зависимости.

В настоящее время я разрабатываю плагин intellij с использованием Kotlin, и когда я его развертываю с помощью «подготовки модуля XXX для развертывания», только зависимости присутствуют в .zip-файле, а не в самом плагине. однако он отлично работает при запуске / отладке его из среды IDE. Обновление: см. Проблему с отслеживанием заранее спасибо

Избегайте конфликта с Kotlin runtime / stdlib с другими плагинами

Я разрабатываю плагин для платформы, написанной на Java. Это требует от меня объединить время исполнения Kotlin и stdlib в jar-файле моего плагина, поскольку платформа также не предусмотрена. Проблема, с которой я столкнулся, – это потенциальный конфликт с другими плагинами, которые также могут быть связаны с временем выполнения Kotlin и stdlib, что приводит к конфликту. Одним […]

IntelliJ (с использованием gradle): не удается найти плагин Kotlin, даже если он установлен

Я пытаюсь построить свой проект с помощью gradle, но кажется, что он не может найти мой плагин kotlin, хотя я и добавил его, используя «установить плагин с диска». Это ошибка, которую я получаю: Не удалось разрешить все зависимости для конфигурации: classpath. Не удалось найти org.jetbrains.kotlin: kotlin-gradle-plugin: 1.0.0-release-1038. Поиск в следующих местах: https://repo1.maven.org/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.0.0-release-1038/kotlin-gradle-plugin-1.0.0-release- 1038.pom https://repo1.maven.org/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.0.0-release-1038/kotlin-gradle-plugin-1.0.0-release-1038.jar Кто-нибудь […]

Как понизить Kotlin в Intellij 15

Для моего проекта мне нужно использовать Kotlin 1.0.0-1038 (бета), но для его установки мне, вероятно, нужно удалить новую версию kotlin, но у нее нет кнопки удаления, где она должна быть. Как я могу понизить Котлин? IntelliJ IDEA 15.0.4