Выделение синтаксиса для файлов сценариев Kotlin в Idea

Я перенесла мою конфигурацию проекта Gradle для использования Kotlin-script: теперь у меня есть как build.gradle и build.gradle.kts и вы можете переключаться между ними, настраивая settings.gradle :

 project(':myProject').buildFileName='build.gradle.kts' 

Проблема заключается в том, что kts build.gradle.kts неправильно загружен: он не разрешает зависимости, говорит, что version = 123 не является допустимым словом и так далее.

Я использую Idea Ultimate 2017.1.3 и kotlin-plugin 1.1.2. В чем проблема? Удаление build.gradle тоже не помогает.

Файлы проекта gradle-script- kotlin правильно загружены.

Вероятно, проблема заключалась в том, что я использовал неправильную версию градиента. Я воссоздал проект, указав град версии 3.5, и теперь он отлично работает. Вероятно, я должен использовать оболочку градиента, чтобы предотвратить такое же возникновение проблемы на машинах других разработчиков.