Переопределить версию зависимостей весеннего загрузчика с помощью gradle kotlin-dsl

SpringBoot поставляется с множеством зависимостей и версиями по умолчанию для них. В groovy-gradle такие версии зависимостей могут быть переопределены:

ext['mockito.version'] = '1.7.5' 

Но это не работает для kotlin-dsl. Я пытался:

 val mockito by extra { "2.12.0" } val mockito.version by extra { "2.12.0" } val `mockito.version` by extra { "2.12.0" } 

Последние два, не компилируют, первый, не выполняют работу.

Как версия может быть переопределена в файле kotlin (я не хочу создавать отдельный файл свойств, если это возможно).

Попробуйте extra["mockito.version"] = "1.7.5"