Проблемы с попыткой создания приложения Kotlin с Android Studio

-Android Studio 1.5.1, Java 1.7.0 amd64, Ubuntu 15.10

-инсталляция kotlin-plugin 1.0.0

-создал новый проект с пустой активностью (уровень API 15)

-Tools-> Kotlin-> Настроить Котлин в проекте

Выбраны опции выбора, все модули, плагин Kotlin версии 1.0.0

Создать build.gradle

apply plugin: 'com.android.application' apply plugin: 'kotlin-android' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "kotlin.org.jjvr.kotlinapplication" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } sourceSets { main.java.srcDirs += 'src/main/kotlin' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.1.1' compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" } buildscript { ext.kotlin_version = '1.0.0' repositories { mavenCentral() } dependencies { classpath "org.jetbrains.kotlin:kotlin-gradle- plugin:$kotlin_version" } } repositories { mavenCentral() } 

-открыть в редакторе MainActivity.java и преобразовать в Kotlin: – kotlin Code-> Преобразовать файл Java в файл Kotlin

 import android.support.v7.app.AppCompatActivity import android.os.Bundle class MainActivity : AppCompatActivity() { override fun onCreate(savedInstanceState: Bundle?) { super.onCreate(savedInstanceState) setContentView(R.layout.activity_main) } } 

-по построении этих ошибок перечислены

Ошибка: только стандартной библиотеке Kotlin разрешено использовать пакет «kotlin»

Ошибка: выполнение выполнено для задачи ': app: compileDebugKotlin'.

Ошибка компиляции.

Любая идея, что происходит?

заранее спасибо

Я получил ту же ошибку, потому что я использовал «kotlin.kotlindemo» в качестве имени пакета. Просто я переименовал пакет, и теперь он работает нормально.