Не могу построить проект с Android Studio 2.3 и Gradle

Я клонировал проект https://github.com/mpcjanssen/simpletask-android.git, но когда я попытаюсь открыть его на Android Studio 2.3 (недавно обновленный), он просто не выполнит проект.

Я постараюсь сработать поэтапно:

1) Удалил все в папке «…. / simpletask-android» с моего жесткого диска.
2) Начинал Android Studio и выбрал новый проект от Github
3) После загрузки исходного кода из Github Android Studio показал мне следующий экран, и я принял поведение Next-Next-Finish, не меняя ничего. введите описание изображения здесь
4) Затем AS приступила к созданию проекта в соответствии с настройками, которые были найдены в корневой папке проекта. На рисунке показано небольшое диалоговое окно.
5) Вдруг AS попросил меня выбрать данные проекта градиента для импорта (?!), Как показано на рисунке
введите описание изображения здесь
6) Следующее сообщение, которое я получил, было на картинке ниже. Проект «simpletask-android» – это не проект на основе Gradle
введите описание изображения здесь
7) Следующая точка – нарушение градиента и рассказывающая мне
«Ошибка: возникла проблема с настройкой проекта»: app '. " а также

«22:22 Не удалось синхронизировать Gradle: возникла проблема с настройкой проекта« Приложение ». Обратитесь к журналу IDE для получения дополнительной информации (Справка | Показать журнал)»

введите описание изображения здесь

Я попытался обновить версию Kotlin, поскольку она говорит в журнале событий, но ничего не произошло …

Я также пытался проверить журнал, как он говорит, и это то, что у меня было:

2017-03-21 22: 22: 54,418 [1045087] WARN – nal.AbstractExternalSystemTask. Возникла проблема с настройкой проекта: app. com.intellij.openapi.externalSystem.model.ExternalSystemException: возникла проблема с настройкой проекта ': app'.

Вызвано: org.gradle.api.ProjectConfigurationException: возникла проблема с настройкой проекта: app.

Причина: kotlin.KotlinNullPointerException
… еще 64

2017-03-21 22: 22: 54,423 [1045092] WARN – ect.sync.idea.ProjectSetUpTask –
2017-03-21 22: 22: 54,423 [1045092] INFO – ect.sync.idea.ProjectSetUpTask – возникла проблема с настройкой проекта «приложение».

Как я могу это исправить?

UPDATE: я удалил AS 2.3 и установил 2.2 Все работало отлично. Тогда я подумал, что это было решено и обновлено AS снова в 2.3 … Так глупо … Я вернусь к началу этой проблемы, ребята …

    Я понял, что случилось …

    Файл build.gradle проекта имел ошибку …

    В оригинале говорится:

    buildscript { //other stuff dependencies { //something else classpath "org.jetbrains.dokka:dokka-android-gradle-plugin:${dokka_version}" } } 

    Но это должно быть:

     buildscript { //other stuff dependencies { //something else classpath "org.jetbrains.dokka:dokka-gradle-plugin:${dokka_version}" } } 

    сделай это:

    1. загрузить последнюю версию градиента с https://gradle.org/releases
    2. извлеките это в ' C:\Program Files\Android\Android Studio\gradle '
    3. открыть студию Android и перейти в « File>Setting>Build, Execution,Deployment>Gradle » и выбрать последнюю папку с градиентом из каталога « Gradle Home
    4. Перезапустите Android Studio и наслаждайтесь им.

    Удачи

    открыть prjectdir / gradle / gradle-wrapper.properties

    и установить

     distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip 

    откройте градиент проекта (не градир внутри модуля) и установите

      dependencies { classpath 'com.android.tools.build:gradle:2.3.0+' } 

    А также проверьте документы .

    Надеюсь, поможет