Ошибка Firebase в приложении для Android

мое приложение показывает ошибку при подписании сбой на firebase .. в журнале это говорит – com, google.firebase.auth не найден. что делать ? Я включил учетную запись электронной почты / пароля в консоли firebase, вот мой код.

public override fun onStart () {super.onStart ()

// Check auth on Activity start if (mAuth!!.currentUser != null) { onAuthSuccess(mAuth!!.currentUser) } } private fun signIn() { Log.d(TAG, "signIn") if (!validateForm()) { return } showProgressDialog() val email = mEmailField!!.text.toString() val password = mPasswordField!!.text.toString() mAuth!!.signInWithEmailAndPassword(email, password) .addOnCompleteListener(this) { task -> Log.d(TAG, "signIn:onComplete:" + task.isSuccessful) hideProgressDialog() if (task.isSuccessful) { onAuthSuccess(task.result.user) } else { Toast.makeText(this@SignInActivity, "Sign In Failed", Toast.LENGTH_SHORT).show() } } } private fun signUp() { Log.d(TAG, "signUp") if (!validateForm()) { return } showProgressDialog() val email = mEmailField!!.text.toString() val password = mPasswordField!!.text.toString() mAuth!!.createUserWithEmailAndPassword(email, password) .addOnCompleteListener(this) { task -> Log.d(TAG, "createUser:onComplete:" + task.isSuccessful) hideProgressDialog() if (task.isSuccessful) { onAuthSuccess(task.result.user) } else { Toast.makeText(this@SignInActivity, "Sign Up Failed", Toast.LENGTH_SHORT).show() } } } 

вот мой модуль градиента

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' apply plugin: 'kotlin-android-extensions' android { compileSdkVersion 26 defaultConfig { applicationId "appname" minSdkVersion 15 targetSdkVersion 26 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support.constraint:constraint-layout:1.0.2' implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support:recyclerview-v7:26.1.0' implementation 'com.android.support:cardview-v7:26.1.0' implementation 'com.android.support:design:26.1.0' implementation 'com.firebaseui:firebase-ui-database:3.0.0' implementation 'com.google.android.gms:play-services-auth:11.6.2' implementation 'com.google.firebase:firebase-auth:11.6.2' implementation 'com.google.firebase:firebase-database:11.6.2' implementation 'com.google.firebase:firebase-storage:11.6.2' testImplementation 'junit:junit:4.12' androidTestImplementation 'com.android.support.test:runner:1.0.1' androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1' compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" } apply plugin: 'com.google.gms.google-services' 

я изменил версию firebase до 11.6.2 от 11.4.2

Intereting Posts
Обработка аннотации Kotlin: возможно ли генерировать метод расширения? Поиск обходного пути для основного конструктора классов данных kotlin Как реализовать шаблон Builder в Котлине? Невозможно использовать все параметры конфигурации с настраиваемой конфигурацией в градиенте с помощью kotlin-dsl Как сделать аргумент по умолчанию? Какова цель Декларации объекта внутри герметичного класса в Котлине? Как разобрать LocalDateTime из RestController в Котлине Ошибка ввода типа. Попробуйте указать тип аргументации: Kotlin Kotlin: Обязательно: kotlin.Boolean. Найдено: kotlin.Boolean? Ошибка компилятора Java при связывании с бандой компилятора kotlin с использованием ant Как установить значение свойства по умолчанию для Kotlin для `this` Котлин: Рекурсия хвоста для взаимно-рекурсивных функций Как переопределить метод setter в котлин? Расширение Kotlin Android не может разрешить «текст», Тип союза между Any? и блок