Как настроить версию Kotlin в Android Studio?

Я сконфигурировал версию Kotlin в проекте build.gradle. Но в Other Settings-> Kotlin Compiler он показывает более старую версию. Как это исправить?

проект build.gradle

Настройки Android Studio

Он не показывает вам устаревшую версию. Допустим, ваша версия плагина «1.1.3», поэтому ваша версия компилятора «1.1» не «1.1.3». Теперь, если вы обновите свой kotlin, зайдя в

Инструменты> Kotlin> Настройка обновлений Kotlin

для ранней версии доступа «1.2», как показано на скриншоте ниже, вы сможете увидеть «1.2» в настройках компилятора Kotlin.

введите описание изображения здесь

В своей студии Android перейдите в Инструменты -> Kotlin -> Настройте обновления Kotlin.

Для получения дополнительной информации вы можете проверить https://segunfamisa.com/posts/setting-up-android-studio-for-kotlin-development

Откройте вам градиент проекта и добавьте эту строку

classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.1.3-2" 

После настройки проекта Gradle вам нужно добавить приложение Gradle. добавить плагин kotlin после плагина android как это

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' 

И последний шаг добавить зависимости

  compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:1.1.3-2" 

И нажмите SYNC Project.